
Prefab UI CVE-2026-120338: Update to 0.21.0 to Close a Sandbox Escape
CVE-2026-120338 affects prefab-ui versions at least 0.14.0 and below 0.21.0, but only when Generative UI is enabled, Deno is installed, and a caller can invoke the tool.[1]
PRACTICAL GUIDANCE BASED ON THE EXPOSURE MODEL • PRESERVE FIRST IF COMPROMISE IS SUSPECTED • Reporting cutoff: November 1, 2026, 22:35 UTC
The bottom line
Practical guidance based on the exposure model: If compromise is suspected, preserve relevant logs and evidence before upgrade, restart, or other remediation.[7] If the full exposure conjunction applies, upgrade prefab-ui to 0.21.0 or later.[2] Then replace or restart every running worker and container so no stale vulnerable process remains.
Verified facts
Why the CVSS models differ
Unauthenticated model: The CVE record assigns CVSS 3.1 10.0 Critical when GenerativeUI is enabled, Deno is installed, and the server has no authentication configured.[1]
Authenticated model: The same record assigns CVSS 3.1 9.9 Critical when the caller is authenticated and allowed to invoke tools.[1]
These are separate access models. A 10.0 score does not mean every prefab-ui deployment is anonymously reachable, and authentication does not remove the issue for an authorized tool caller.
Check the complete exposure conjunction
A deployment is in scope only when all four conditions hold: prefab-ui >=0.14.0 and <0.21.0; optional Generative UI is enabled; Deno is installed; and the caller can invoke the tool.[1]
What changed in 0.21.0
The fix revokes Deno read, write, and network permissions after bootstrap and before generated code is accepted.[1][4]
The fixed runner also documents that --no-prompt prevents later permission requests from granting those permissions again.[1]
Practical guidance based on the exposure model
- Inventory precisely. Record the exact installed prefab-ui version and deployment provenance.
- Preserve first if compromise is suspected. Preserve relevant logs and evidence before upgrade, restart, or other remediation.[7]
- Upgrade. Move to prefab-ui 0.21.0 or later.[2][5]
- Reduce exposure until upgrade. Do not register
GenerativeUIon a server untrusted clients can reach.[2] - Replace running processes. Replace or restart all workers and containers after deploying the fixed version.
- Verify the rollout. Confirm no stale workers remain and test the required Generative UI behavior after the change.
Exploitation status and limits
CVE-2026-120338 was not present in the captured CISA Known Exploited Vulnerabilities catalog version 2026.10.30 at the November 1, 2026, 22:35 UTC cutoff.[6] This is a bounded catalog observation, not proof that exploitation has never occurred.
Sources
- CVE Program record: CVE-2026-120338
- JFrog Security Research advisory JFSA-2026-001699278
- Prefab v0.21.0 release
- Prefab fix commit 030f074
- PyPI prefab-ui 0.21.0
- CISA Known Exploited Vulnerabilities Catalog
- NIST SP 800-61r3 (April 2025)
This report reflects the source captures available through November 1, 2026, 22:35 UTC. The CVE record references GHSA-595q-jv4r-q7j9.[1] Neither captured GitHub route was publicly readable at the cutoff, so this article does not rely on that advisory as a readable source.
